ID บทความ: 000089237 ประเภทข้อมูล: ข้อความแสดงข้อผิดพลาด การตรวจสอบครั้งล่าสุด: 20/05/2022

ข้อผิดพลาด: "ImportError: libpython3.9.so.1.0: ไม่สามารถเปิดไฟล์ออบเจ็กต์ที่ใช้ร่วมกันได้" เมื่อปรับใช้ชุดเครื่องมือOpenVINO™ผ่าน Heroku*

BUILT IN - ARTICLE INTRO SECOND COMPONENT
สรุปข้อมูล

ขั้นตอนการเพิ่มการสนับสนุนการพึ่งพาที่ใช้ apt สําหรับการปรับใช้ชุดเครื่องมือ OpenVINO™ ผ่าน Heroku

คำอธิบาย

ไม่สามารถปรับใช้ชุดเครื่องมือ OpenVINO™ ผ่าน Heroku:

ผู้นําเข้า: libpython3.9.so.1.0: ไม่สามารถเปิดไฟล์ออบเจ็กต์ที่ใช้ร่วมกัน: ไม่มีไฟล์หรือไดเรกทอรีดังกล่าว

ความละเอียด
  • เพิ่มไฟล์ runtime.txt ลงในไดเรกทอรีรากของแอปเพื่อ ระบุรันไทม์ Python:
    python-3.9.1

  • เพิ่ม ไฟล์ Aptfile ไปยังไดเรกทอรีรากของแอปเพื่อระบุที่เก็บแบบกําหนดเอง:
    libpython3.9

ผลิตภัณฑ์ที่เกี่ยวข้อง

บทความนี้จะนำไปใช้กับ 2 ผลิตภัณฑ์

เนื้อหาในหน้านี้เป็นการผสมผสานระหว่างการแปลเนื้อหาต้นฉบับภาษาอังกฤษโดยมนุษย์และคอมพิวเตอร์ เนื้อหานี้จัดทำขึ้นเพื่อความสะดวกของคุณและเพื่อเป็นข้อมูลทั่วไปเท่านั้นและไม่ควรอ้างอิงว่าสมบูรณ์หรือถูกต้อง หากมีความขัดแย้งใด ๆ ระหว่างเวอร์ชันภาษาอังกฤษของหน้านี้กับคำแปล เวอร์ชันภาษาอังกฤษจะมีผลเหนือกว่าและควบคุม ดูเวอร์ชันภาษาอังกฤษของหน้านี้