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The Intel® Arria® 10 variations of the 50G Interlaken IP core feature a simulating testbench and a
hardware example design that supports compilation and hardware testing, to help you understand usage.

When you generate the example design, the parameter editor automatically creates the files necessary to
simulate, compile, and test the design in hardware. You can download the compiled hardware design to
the Intel Arria 10 GX Transceiver Signal Integrity Development Kit. The testbench and demonstration
example design are available for a wide range of parameters. However, they do not cover all possible
parameterizations of the 50G Interlaken IP Core.

In addition, for most IP core variations, Altera® provides a compilation-only example project that you can
use to quickly estimate IP core area and timing.

Figure 1-1: Development Steps
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Directory Structure

Figure 1-2: Directory Structure for the Generated Example Design

[j <ilk_core_50g_0_example_design>
ﬂ ilk_50g.ip

[j example_design_a10 fj ilk_50g

" | example_design.gpf @ <design component>

ﬂ example_design.qgsf ‘B
sim

ﬂ example_design.sdc
oty
ﬂ example_design.sv

ilk_50g.
ﬂ ilk pkt checker.sv ﬂl _»Ug.cmp

ilk_50g.csv
ﬂ ilk_pkt_gen.sv ‘G 9

ﬂ ilk_top.v |
ﬂ ncsim.sh ‘G ilk_50g.html

= ik_sog.aip
ﬂ one_shot.v
ﬂ ilk_50g.sip
sysconsole_testbench.tcl
ﬂ ﬂ ilk_50g.spd

ﬂ test_agent.sv ﬂ
ilk_50g.xml
test_dut.
ﬂ estdutsv ﬂ ilk_50g_generation.rpt

ﬂ vestest.sh
ﬂ vlog.do
ﬂ vlog_pro.do

The hardware configuration, simulation, and test files are located in <example_design_install_dir>/
example_design_al0.
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Design Components
Figure 1-3: Example Design Block Diagram
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Figure 1-4: Procedure
Start Parameter > Specify IP Variation Select > Specify Initiate
Editor and Select Device Design Parameters Example Design Design Generation

Follow these steps to generate the Intel Arria 10 hardware example design and testbench:

1. In the IP Catalog (Tools > IP Catalog), select the Intel Arria 10 target device family.

Note: The Quick Start hardware example design is only supported in Intel Arria 10 devices. The

testbench is available for variations that target Intel Arria 10 devices or Stratix® V devices.

2. In the IP Catalog, locate and double-click 50G Interlaken. The New IP Variation window appears.

3. Specity a top-level name for your custom IP variation. The parameter editor saves the IP variation
settings in a file named <your_ip>.qsys.

4. You must select a specific Intel Arria 10 device in the Device field, or keep the default Intel Quartus®
Prime software device selection.

5. Click OK. The parameter editor appears.

Quick Start Guide
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Figure 1-5: 50G Interlaken Parameter Editor

M parameters &2 ™
System: unnamed  Path:ilk_core_S0g_0

50G Interlaken Details I
lk-core-500 Generate Example Design... I

- Example Design

[= Available Example Design |
Select Design:

|Imerlaken Serial Loopback Design |v|

[* Example Design Files |
[v] Simulation

[v] Bynthesis

[~ Generated HDL Format |

Cenerated HOL Format; =

[* Target Development Kit |
Select Board:

|Arria 10 QX Transceiver Signal Integrity Development kit |v|
Family, Arria 10 Dewice: 104X 11553F451250

This example design supports generation, simulation and Quartus compile flows for any selected device,
The hardware support is provided through selected Development kit(s) with a specific dewice.

6. On the IP tab, specify the parameters for your IP core variation.

7. On the Example Design tab, select the Simulation option to generate the testbench, and select the
Synthesis option to generate the hardware example design.

Note: At least one of the Simulation and Synthesis check boxes from Example Design Files must be
selected to allow generation of Example Design Files.

8. For Generated HDL Format, only Verilog is available.
9. For Target Development Kit select the Intel Arria 10 GX Transceiver Signal Integrity Development

Kit. If you select a development kit, then the target device (selected in step 4) for Example Design is
changed to match the device on target board.

10.Click the Generate Example Design button.

Related Information
50G Interlaken IP Core Parameter Settings
Provides information about the 50G Interlaken IP core customization by specifying parameters.
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Simulating the Design

Figure 1-6: Procedure

CIENLRI0 Run Analyze
Testbench — W . ) . — 4
. <Simulation Script> Results
Directory

Follow these steps to simulate the testbench:

1. Change to the testbench simulation directory <exanpl e_desi gn_i nstal | _di r >/ exanpl e_
desi gn_al0/t est bench.

2. Run the simulation script for the supported simulator of your choice. The script compiles and runs the
testbench in the simulator. Your script should check that the SOP and EOP counts match after
simulation is complete. Refer to the table Steps to Run Simulation.

3. Analyze the results.

Table 1-1: Steps to Run Simulation

T T
Modelsim For Quartus Prime Pro edition:

o Inthe command line, type - do vl og_pro. do

For Quartus Prime Standard edition:

o Inthe command line, type - do vl og. do

NCSim In the command line, type sh ncsi m sh

VCS In the command line, type sh vcstest. sh

A successful simulation ends with the following message:

Test PASSED

Compiling and Testing the Design

Compile Design .
inQuartusPrime %  SetupHardware  —P» Program Device > Test Design
Software in Hardware
QuickStart Guide Altera Corporation
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To compile and run a demonstration test on the hardware example design, follow these steps:

1. Ensure hardware example design generation is complete.

2. Open the Intel Quartus Prime project <user-specified location>/example_design_al0/quartus/
example_design.qpf, where <user-specified location> is the directory location you specified when you
generated the testbench and hardware example design.

3. On the Processing menu, click Start Compilation.

4. After successful compilation, a .sof file will be generated in your specified directory. Follow these steps
to program the hardware example design on the Intel Arria 10:

a.

b
c.
d

oo

g.
h.

i.

On the Tools menu, click Programmer.

. In the Programmer, click Hardware Setup.

Select a programming device.

. Select and add the Intel Arria 10 GX Transceiver Signal Integrity Development Kit to which your

Intel Quartus Prime session can connect.
Ensure that Mode is set to JTAG.

Select the Arria 10 device and click Add Device. The Programmer displays a block diagram of the
connections between the devices on your board.

In the row with your .sof, check the box for the .sof.
Check the box in the Program/Configure column.
Click Start.

5. After the hardware example design is configured on the Intel Arria 10 device, in the Intel Quartus
Prime software, on the Tools menu, click System Debugging Tools > System Console.

6. In the Tcl Console pane, type sysconsol e_t est bench. tcl .

7. Type run_exanpl e_desi gn.
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The example design demonstrate the functionalities of the 50G Interlaken IP core. You can generate the
design from the Example Design tab of the 50G Interlaken graphical user interface (GUI) in the IP
parameter editor.

Features

o Internal TX to RX serial loopback mode.

 Automatically generates fixed size packets.

 Basic packet checking capabilities.

« You can use system console to reset the design for re-testing purpose.

Hardware and Software Requirements
Altera uses the following hardware and software to test the example design:

e Quartus Prime software

« System Console

+ ModelSim-AE, Modelsim-SE, NCsim (Verilog only), or VCS simulator
 Arria 10 GX Transceiver Signal Integrity Development Kit for hardware testing

Functional Description

The hardware example design connects system and PLL reference clocks and required design components.
After you program the device on the Arria 10 GX transceiver signal integrity development board, the
example design configures the IP core in internal loopback mode and generates packets on the IP core TX
user data transfer interface. The IP core sends these packets on the internal loopback path through the
transceiver. After the IP core receiver receives the packets on the loopback path, it processes the Interlaken
packets and transmits them on the RX user data transfer interface. The example design checks that the
packets it receives on the IP core RX user data transfer interface are consistent with the packets sent in.
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Figure 2-1: Arria 10 50G Interlaken IP Core Example Design Block Diagram

Arria 10 GX Transceiver Signal Integrity Development Board

Arria 10 GX Device

Hardware Example Design

ATXPLL

Packet
Generator

—>

1

Control & Status
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Packet
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System PLL

tx_serial_clkl

pll_ref_clk PLL Reference
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The hardware example design includes external PLLs. You can examine the clear text files to view sample
code that implements one possible method to connect external PLLs to the 50G Interlaken IP core.

The hardware example design packs six Interlaken lanes in a transceiver block, and connects all of the
channels in the same transceiver block to a single ATX PLL. The IP core connects ATX PLL to the

50G Interlaken IP core t x_pl | _I ocked and t x_pl | _power down ports. This simple connection model is
only one of many options available to you for configuring and connecting the external PLLs in your

50G Interlaken design.

Related Information

o Arria 10 GX Transceiver Signal Integrity Development Kit product webpage
+ 50G Interlaken MegaCore Function User Guide
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Example Design Behavior

Immediately following configuration on the Arria 10 device, when you type r un_exanpl e_desi gn in
system console, the 50G Interlaken IP core hardware example design performs the following actions:

1. Resets the 50G Interlaken IP core.
2. Configures the 50G Interlaken IP core in internal loopback mode.

3. Sends a sequence of 100 256-byte Interlaken packets with predefined data in the payload to the TX user
data transfer interface of the IP core.

4. Checks the received packets and reports the status.

The packet checker included in the hardware example design provides the following basic packet checking
capabilities:

o Checks that the transmitted packet sequence is not violated
o Checks that the received data matches expected values

Interface Signals

Table 2-1: Arria 10 50G Interlaken IP Core Hardware Example Design Signals

cl k50 Input System clock input. Clock frequency
must be 50 MHz.

pl1_ref _clk Input 1 Transceiver reference clock. Drives the
RX CDR PLL.

rx_pin Input Number of lanes Receiver SERDES data pin.

tx_pin Output Number of lanes Transmit SERDES data pin.

sys_pll _reset_n Input 1 System reset.

Register Map

Table 2-2: Example Design Register Map

N N

8'h00 Reserved
8'h01 Reserved
Design Example Description Altera Corporation
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N I

Following bits indicates system PLL reset
request and enable value:

8'h02 System PLL reset RO - Bit [0] - sys_pll_rst_req
o Bit[1] - sys_pll_rst_en
8'h03 RX lane aligned RO Indicates the RX lane alignment.
8ho4 WORD locked rRo | [INUM_LANES-1:0] - Word (block)
boundaries identification.
8'ho5 Sync locked RO [NUM_LANES—I:O] — Metaframe synchroni-
zation.
8'h06 - 8'h09 CRC32 error count RO Indicates the CRC32 error count.
8'hOA CRC24 error count RO Indicates the CRC24 error count.
Following bits indicate:
. . o Bit [3] - TX underflow signal
8'hOB Overflow/Underfl 1 RO
vertlow/Underflow signa « Bit [2] - TX overflow signal
« Bit [1] - RX overflow signal
8'h0C SOP count RO Indicates the number of SOP.
8'h0D EOP count RO Indicates the number of EOP

Indicates the number of following errors:

o Loss of lane alignment

8'hOE Error count RO o Illegal control word

o Illegal framing pattern

» Missing SOP or EOP indicator

8'hOF send_data_mm_clk RW Write 1 to enable the generator signal.
8'h10 Reserved
8hl1 System PLL lock RO PLL lock indication.

Note: « Example design register address starts with 0x20** while the 50G Interlaken core register
address starts with 0x10**.

o Access code: RO—Read Only, and RW—Read/Write.
« System console reads the example design registers and reports the test status on the screen.

Altera Corporation Design Example Description
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Table A-1: Revision History

T

Made following changes to Simulating the Design section:

2018.03.22 » Corrected simulation directory location.
o o Updated command to simulate the testbench in NCSim and VCS simulators.

« Updated simulation ends display message.

« Changed the title to 50G Interlaken Design Example User Guide.

» Corrected the Figure: Arria 10 50G Interlaken IP Core Example Design Block
2016.10.31 .

Diagram.

» Updated the Figure: Directory Structure for the Generated Example Design.

2016.05.02 Initial release
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